'Hey LipSurf' not working

Hi! I’ve tried setting up LipSurf for my friend who’s been a Dragon user for many years. So much of it seems so promising, but there are a few things that we can’t quite get working.

  1. Principally, the ‘Hey LipSurf’ command does not seem to work. He bought premium, and is running a Windows 10 machine. I thought perhaps it was his machine and internet so I bought premium as well and tried it out on a macbook air at home, but it also does not work for me.
  2. I’m also curious, is there an ‘unpause’ command? Otherwise what is the difference between ‘stop listening’ and ‘sleep’?
  3. Is there any way to click on items that don’t get tags? For example in Google Docs the text page lost focus, and so we could only click all the buttons around the page, but could not refocus with voice and go back into dictating text.

I’m definitely excited for the direction this is going even if it might not yet meet my friend’s needs. It seems like it will quickly. Thanks!

1 Like

Some other examples of being stuck not able to click things were when I was trying to use LipSurf to submit Feature Requests .

I could not get rid of these error messages, which blocked me from selecting the dropdown menu.

I could not figure out how to get a selection from the dropdown.

Welcome Corbin! Thank you for your detailed and clear feedback, exactly the kind I love!

  1. Try changing the microphone in the settings under “wake word” and/or the sensitivity. The default selection has had problems for others as well, we will improve it.

  2. “Stop listening” leaves all the LipSurf UI intact - the help box, tags etc. To unpause just start it again (use “hey LipSurf”, click the icon or use the hotkey)

  3. How about a click grid, where you narrow down a part of the page to click. We can add that.

Nice catch! I’ll look into why those error messages aren’t getting tags.

Let me get back to you on the drop-down selection. It should work. Usually you can say “click [text in drop-down]” or use tags. But I’m on mobile right now so I’ll need to check when I’m back in the office later.

  1. Oh nice, I got ‘Hey LipSurf’ working on my laptop, even with the built in mic while sitting outside! I’ll try again with my friend later today and circle back here.

  2. Got it, thanks for clarifying!

  3. I think that would be a really nice feature to fall back on when the nicer navigation isn’t working for whatever reason.

I created a screen capture of the dropdown issue if that’s helpful. Let me know if there’s another way you’d rather view it than a Dropbox link.

1 Like

One more thing I ran into which might be a Chrome limitation, but maybe you’ve seen this. If I end up on a page that doesn’t resolve, such as I accidentally ended up on http://surf.com/ when trying to get to lipsurf.com, then I can’t navigate away anymore by voice. Do you know of any way around this?

There’s no way to show the live text there (a Chrome limitation as you correctly surmised), but certain commands should still work. You should still be able to use “close tab”, “new tab”, “tab #”, etc.

Just wanted to circle back, after a classic problem solving restart we got ‘Hey LipSurf’ working on my friends computer as well!!

1 Like

Thanks for the screencast. I see the problem now - it has to do with this forum and not LipSurf. That particular forum button was not designed with accessibility in mind. I will fix the issue - either in the forum code or in LipSurf as a workaround. Good catch!