Lip Surf not working in certain scenarios

Hi, following the 4.00 update, I noticed that Lip Surf’s scrolling commands such as scroll down, scroll up, and auto scroll, no longer work when the top Google search bar (the omnibar) Is highlighted. Normally, this wouldn’t be much of a problem, but I have set the website version of a new tab page extension called Tabliss as my homepage using the custom URL function. This website automatically highlights the Omnibar every time I open a new tab, so now I have to click my screen every time I open a new tab in order to scroll up or down on websites. I’m not sure if this change was intentional and this is a rather small inconvenience, but I wanted to point it out in case it was a small glitch.

Additionally, I’ve noticed that when I’m watching a video on YouTube, Lip Surf doesn’t seem to recognize any of my commands, including media control commands, such as pause or play. Occasionally, it will pick up the pause command after repeating it several times. It’s like if it doesn’t hear my commands which is weird as this happens with or without my headphones. While I normally use headphones, I tried enabling no headphones mode and made sure that lips surf is not automatically paused while playing media, but the issue still persists.

I would love to know if anyone has experienced these issues or if there’s a fix to them, thank you!

Thanks, we’ve just confirmed this. We’ll put a fix in shortly.

This seems like a feedback issue. The headphones should alleviate that, so it’s strange that you didn’t notice any difference. Can you make sure the right microphone is selected here: chrome://settings/content/microphone?search=microphone ?
If you turn your volume down or mute the video, do the commands work fine as you would expect?

Hi Miko, thanks for the quick response. I tried lowering or muting the volume, but there doesn’t seem to be any improvement on how the commands work. Everything works smoothly only after I pause the YouTube video manually.

Just checked the microphone settings, and the correct microphone was selected (Logitech USB headset). I tried other websites with audio other than YouTube, and the audio also seems to interfere with Lip Surf picking up what I’m saying despite using headphones. Sometimes it works and transcribes the commands I say, but most of the time it does nothing.

I wonder what the issue might be. Not sure if it matters but my device is a Chromebook btw.

I should have been more clear, did you lower/mute it on YouTube? Using the controls on youtube, or your computer. Because I was referring to lowering/muting it on the YouTube player to see if that makes the commands work better. If it does, it means your output audio is likely feeding back in. There might be a chromebook setting to fix that, let’s just narrow it down first.

Okay yeah, so I tried muting the video using the YouTube player itself, and it did make the commands work as usual. Previously, I only lowered the volume on my computer. The issue seems to be what you described.

OK so as mentioned the issue seems to be that your computer’s output audio is being fed back into the input. I don’t know how to fix it on your specific machine, but I would try playing with different microphone settings in Chrome or reaching out to the customer support of the manufacturer. I can imagine it could also be a hardware defect.