Using commands while in dictation mode

Is there any way for lip surf to recognize commands while in dictation mode? I use LipSurf a lot while chatting in Discord from the web app, and I would really like to be able to use a command like press enter (so I don’t have to hit enter on my keyboard and can instead be totally hands-free) or new tab while in dictation mode. I thought maybe a command but I can’t seem to get commands to work as shortcuts, like when I create a shortcut for “open Discord” with “go to discord.com” in the second field, the preview will show the text but it won’t light up green and respond, and yes I’ve made sure it’s in normal mode.

Any ideas? Is there maybe something I’ve totally missed? Thanks!:slight_smile:

Hmm yes, it would make a lot of sense to have “press enter” available. It’s tricky though, because sometimes people literally need to write “press enter” or “new tab” or another phrase that’s also a command.

Sorry, I don’t really understand what you’re saying here. Are you saying you have a custom shortcut for “open Discord” -> “go to discord.com” and it’s not working? Can you show me a screenshot of the shortcut in your options under “Custom Homosyns”?

Success! I have discovered the problem. So, what I was doing was copy-pasting the URL from my location bar. These days, this does not include the www. I previously been able to get these types of command shortcuts to work, but I hadn’t been able to figure out what the difference was. I think the first one or two I did, I didn’t use the location bar copy paste and instead typed it in myself, which means I added the www out of habit.

So, I figured what the hell, it’s worth a shot, and look I’ve been the troubleshooter for so many professionally employed Geeks over the past two decades that believe me I have stories about the bizarre things that turned out to be the cause of the problem. I have lost track of the number of times that somebody has asked me why in the world I ever even thought to check that in the first place, because it was so freaking out there. (The answer is usually sleep deprivation.)

At least this one makes some amount of sense, but the www hasn’t been required in URLs for a lot of things for over half a decade or so now, and it’s usually not included when you go to copy paste like I did from the location bar. So, basically it’s recognized www.discord.com but not discord.com, which is not immediately obvious. Also, when I had previously tried typing out http://www.discord.com in the shortcut (it is somewhat hilarious to me that I cannot get lip surf to recognize the word homosyn for the freaking life of me) oh, that didn’t work. I had tried it because when I copy pasted from the location by the first time it included a URL starting with https oh, and I thought maybe the problem was the security level.

I don’t know if anybody else has experienced this? Now that I know it’s a thing, it’s not really a problem, but it was not obvious at all. If this is working as intended, I highly suggest that it be included in an FAQ somewhere, so as to avoid headaches for other people like me, and more support tickets for you. :slight_smile:

Regarding commands during dictation: I can think of a few potential Solutions. One would be combining the verbal command with holding down a key, kind of like push to talk. Another would be adding a preface word such as the literal command in dication mode (although so far I haven’t been able to get that to work, it just typed the word literal and then whatever it was I was trying to actually have it type properly). And a third one I can think of is maybe a spoken alphanumeric / symbol code preceding the command, something that is an unlikely combination for practical use, whereas new tab or press enter are common phrases if you’re working in Tech or writing Tech documentation or articles. Just some thoughts. :slight_smile:

@Aelin_Lovelace you can use just “go to discord.com” I’ve tried that and it works fine. You likely had something else going on. I’m guessing you had the casing off. Custom shortcuts are case-sensitive so if you see the live transcript coming back as “Discord” it would need to be capitalized that way in your custom shortcut.

Custom shortcuts UX will improve to address this.

cannot get lip surf to recognize the word homosyn

Well, it’s not a real word, so that’s not surprising to me. Perhaps we’ll change that feature name to a real word.

such as the literal command in dication mode (although so far I haven’t been able to get that to work

We have a fix for the “literal” command in the upcoming v3.14.0, sorry about that.

Actually, messing around with the cases is the first thing I tried. I tried literally every combination and it still did not work until I included the www. I just tested it out now by creating another shortcut called visit Discord without the www, and it did not light up green as it does when it recognizes a command or dictation. I can take a screenshot or I can take a video capture if that would help.

I have noticed that it is inconsistent though. The first couple days I was using lip surf, I used a shortcut without the www and it worked but it’s pretty much not been responding since then. that would be like a couple weeks ago or so. Inconsistent bugs are such a pain in the arse because they never freaking happen when you’re looking for them.

Yeah I wasn’t surprised that it didn’t recognize the word either. My Android tablet has a similar feature, although not as robust, and they call it the personal dictionary. Maybe call it custom vocabulary? Or something in that general area? Just a couple thoughts.

OMG thank you so much for the fix to the literal command. This is not meant in any way to be derogatory, but the impression I have gotten is that lip surf has a small development team. My ex-partner of 10 years is a Linux sysadmin, and they have worked primarily with start-up companies. I have noticed that lip surf has a striking resemblance to many of the companies my ex-partner has worked with. If I’m incorrect please let me know. :slight_smile:

I have a sort of related question… Because I spent so many years as my ex-partners “Guinea Kitty” that it is reflex for me to notice bugs and try to troubleshoot them myself. Before going to support. Y’all are busy enough that I would prefer to fix it myself rather than give you guys more stuff to do when I can just handle it myself.

Would it be better for me to create a master thread for bugs and Etc so I can just add a reply to the thread rather than continually creating new ones? I noticed that the GitHub issue page for lip surf have very few reports, although that doesn’t necessarily mean anything because the average computer user that posts to a support forum is someone like my mom who has no idea how anything computer-related works. But I grew up with computers; even though I’m 35, my folks acquired a Mac and an IBM computer in 1993 and 1994. Take a wild guess at who got volunteered to figure out how to solve various computer-related issues. If you would guess somebody with a first name beginning with the letter A, and a last name beginning with L, congratulations you are dead on. Sorry but there’s no prize for that one. :stuck_out_tongue:

Between this and my Guinea Kitty status, I’m used to providing both fleshed-out suggestions and bug reports that detail the issue that I am having. I’m inclined to create a forum thread for ongoing bug reports and suggestions for how to improve the functionality and accessibility of the extension. I’m not sure if I mentioned it or not but I have multiple medical conditions that affect my hands in such a way that I have in the past literally spent an entire world of warcraft raid crying from pain because simply pressing the keys was excruciatingly. Currently the conditions that caused the worst of it have gone into remission oh, but there is no guarantee that will last forever never mind all the other ways that I managed to screw up my body, like sleeping on my back in the same position all night for 14 hours.

I’ve tried virtually every software I can get my hands on whether legally or not and lip surf has been the best option. Dragon NaturallySpeaking has a lot of features but my computer is from 2009 and has a really terrible “green” CPU that is under clocked and cannot be adjusted, so Dragon does not exactly work for me right now. This may change when my partner comes up to visit and brings the computer components that he bought for me that will be a serious upgrade. But as it is I find lip surf to be three times as fast as dragon. Everything else I looked into was either worthless or had a trial version that disabled the main features that I wanted, primarily being able to use voice recognition in something like Discord.

So, I would like to help but I wanted to check first before making a post like that because some Forum admins get a bit touchy about stuff like that. I’m also interested in the plug-in system but I can’t seem to find any existing plugins for me to try out to see what sort of things can be done with plugins. The explanation given on the documentation page did not really give me the information about what the plugins can do and what their limits are. And I know just enough about coding to get myself into trouble, lol. :roll_eyes:

Would my bug reports and thoughts / suggestions be useful? And if they would be, what would be the best way for me to go about this? The master thread is just one idea and maybe there’s something that would work better for you guys. I’m flexible. :slight_smile:

I’ve been using this extension for like maybe 2 weeks now and it is already making a huge difference for me. Since I’m familiar with, well, basically post-release QA, I would like to help if I can. Let me know. :slight_smile:

Yeah, it would be best to make a screen recording. There’s no bugs with the custom shortcuts that would cause them to fail to execute that I’m aware of. The other thing I can imagine happening is if the text never turned completely white (only the muted white) that means it didn’t have a high enough confidence. If there’s not enough confidence for a transcript, it won’t execute any command.

Sorry, your message is kind of long so I will have to respond to other parts when I have more time. We have a lot to balance between support and development.

I totally understand. My ex’s favorite job was at a startup only two years old when they joined the company, and they were one of two systems administrators. There was never enough time and a lot of 3 a.m. work. :slight_smile:

Okay, I thankfully have two computers to work with, so I reverted one to factory settings go to, and I imported the custom shortcuts from May 23rd. The shortcuts from then, when imported, do not work and the white does bright up, but it does not turn green. However, I can add the exact same shortcut string and command and it works fine now. I didn’t try to make a command shortcut until after the latest update, so maybe there’s something that was changed that fixed it, but that doesn’t explain why it doesn’t work when it’s imported from the Json file. Where should I send you a copy of the file so you can take a look at it?

As an additional note, I’m testing on both Mac and Windows, which I don’t think should make a difference, but data point. :slight_smile:

I think I found the problem. So, earlier today before the update, lip surf stopped registering my words and I know that it was picking up on my mic because saying hey lip surf activated it. I uninstalled the extension and reinstalled. I then went and loaded my custom shortcuts. None of the command shortcuts worked, and the word replacement ones didn’t work either.

So I reverted to factory default, but saying or clicking add shortcut did not bring up the dialog window. I edited the Json file to include nothing, and that let me add shortcuts, but any new command shortcuts only lit up white and did not actually go to the site. I reverted again and I’m not sure why it let me add shortcuts that time, but I manually entered the exact same shortcut that it was not loading when imported, and it worked fine.

I’m probably going to look at finding where the Json file for the extension is located and see if I can directly edit it and what effect that has. Because, I had over 60 short cuts. I really don’t want to do them manually again. I will update with the results, but since there was just an update rollout I wanted to make sure to let you guys know ASAP in case it is somehow related.

Dragon overcomes this problem by making the commands use a slightly different cadence. The commands are just a little bit faster than regular dictation. Just putting some ideas into the universe.

1 Like