🚀 v4 a̶l̶p̶h̶a̶ ̶b̶e̶t̶a̶ c̶h̶a̶r̶l̶i̶e̶ Ready!

UPDATE 6/29/21 - v4 officially released!
UPDATE 6/27/21 1:38 CT - Charlie now available w/ various fixes
UPDATE 6/3/21 20:00 CT - Beta now available w/ various fixes

After many months of intense development, we’re excited to announce the alpha beta charlie for the new major release v4.0.0 is now ready for testing!

Version 4 is a foundational change that paves the future for a much more powerful, and customizeable voice control platform, and also comes with long-requested features.

If you want to get an early look and give feedback before the permanent release, this is your chance! But beware, it has bugs and is not intended for use outside of testing - don’t rely on it for anything important and don’t intend on saving any customizations you make to it (eg. custom shortcuts/corrections).

You will have to uninstall the alpha beta charlie version later to keep LipSurf up-to-date with the mainline version.

:sunglasses: Cool new features :sunglasses:

  • Automatic dictation - just start speaking if any textbox is selected
  • Advanced custom shortcuts
  • Custom shortcut manager
  • Replacements are underlined and can be modified via the live transcript
  • Option for number tags instead of letters

:warning: BEWARE :warning:

Known Issues (will be fixed before v4 mainline release)

  • Needs new tutorial
  • Import/export custom shortcuts not working
  • Custom shortcuts are not yet editable
  • Disabling homophones not working
  • Doesn’t work on Google Docs, Medium, WhatsApp, or FB chat yet

How to Install

  1. Download: https://cdn.lipsurf.com/lipsurf_4-0-0_charlie.zip
  2. Follow these instructions: Checking Version & Updating | LipSurf User Manual

Try to download “v4Alpha” by clicking to http://cdn.lipsurf.com/lipsurf_4-0-0_alpha.zip, but the downloading is not starting. Is it the problem of my computer or something other?

1 Like

woops, should have been https, fixed now!

After clicking to „New“ icon on upper bar (Chrome browser), starts transfering to http://devhost:8082/updates/ and appears the warning, that can’t access the site. May be something wrong with my computer, but may be something other.

Sorry about that, it’s a benign error, you can safely ignore it. Also, I have just uploaded a newer version, the beta which has it fixed and can be downloaded via the updated link above!

When using of Lipsurf I have no need for example, in “Dictionary for Japanese Language Learners v4.0.0” (avaliable in settings). I change this option in settings from “ON” to “OFF” position and close Chrome front page. After new opening of Chrome front page and opening of Lipsurf settings, above mentioned option is newly active (“ON” position).

Am I right, that settings changing from “ON” to “OFF” is active only till closing of Chrome front page and they are automatically returning to “ON” position after each renewal of Chrome front page?

I’m not able to reproduce this problem. The settings should persist - e.g. if you disable a plugin it should stay disabled unless you re-enable, reset to factory defaults, or reinstall LipSurf.

What do you mean by renewal of the Chrome front page? Just opening a new tab, or changing the new tab page, or something else?

I tried it but there is a problem with adding shortcuts. When added, let’s say “Previous step” becomes “Previous tab”. All that’s saved is “Previ”.

Can you show me a screenshot of the added shortcut? Or make a screencast or give me exact steps of what you’re doing. Not able to reproduce that issue :confused:

@Dmitri_H @ghmryy I have just uploaded a newer version “Charlie” - the custom shortcuts manager is now much improved, and import/export are working. Tutorial is also updated. Let me know how it works for you!

v4 now officially released! Updates | LipSurf Enjoy!

When saying „movie“ is not happening transfer to the site. Appearing only „go to…,“ (see second screenshot), but transfer to the site does not happen.
Please give your advise, what shall be done that after saying „movie“ happens transfering to the site?
I have V4.0.0. installed.

1 Like

That looks right. And I just tried it, it works for me. Hmm, we will keep trying to reproduce it on our end.

May be the problem is that “Language & dialect” in settings is selected as “Russian” and “Output” starts with “go to…” which is in English ?

Thanks for that added information! Yes, that would cause a problem. Can you try: “перейти на [the url]”? Also, to add the shortcut, first make sure you’re in Russian, then say anything, then click the live transcript when it appears at the top and switch to the “custom shortcut” tab.

Let me know if that helps.

In settings only (!) I have changed from “go to” to “перейти на” and the problem is now resolved, happens quick transfering to the web-site.

1 Like

Since upgrading whenever I open chrome, Lipsurf opens its tutorial, even after I click “close tutorial”. Also the settings page also sometimes spins like this:

I had to click factory defaults, and then it seemed to be ok