WaniKani update may have broken LipSurf plugin

Seems WaniKani pushed a big site change today and reviews via LipSurf are not working. Most/a lot of userscripts are broken too

Tested Mac & Windows, same thing: LS just does auto-dictation instead of submitting or marking wrong, etc. Haven’t tried lessons yet


Thanks for the heads up, we’ll take a look.

1 Like

I’m having the same issue as well. userscripts don’t work and the japanese function on lipsurf isn’t working.

Hi @Miko,

Is there any update on this issue? This is the only this I use LS for and I’ve struggled to use WK since the breaking change.

I’m a software engineer myself and have worked on many OSS – is this plugin open-source? I’d be more than happy to fix it this week if so. If it’s closed, perhaps you could send me the source for the WK plugin?


1 Like

No update yet. I’ve emailed you.

Any update/ETA on this? Lipsurf is the primary way I interact with wanikani due to wrist injury, and I would love to get back to my practice.

Subbed for exactly this and very disappointed to see it’s not even working

1 Like

It’s being worked on. Will be fixed in the next release.

is wanikani still broken? :frowning:

1 Like

Is there an ETA? It’s been many months now that I’ve not been able to use wanikani due to this.

1 Like

Is WaniKani no longer working with Lipsurf? I resubscribed to Plus after a year’s vacation and I am getting a message that I need Premium. I switched it onto developer mode and uploaded a plugin and added lightning mode with Tamper Monkey but still not working. Is it required to purchase premium to use with Wanikani now?

Yeah I also got the LipSurf plus only for wanikani purposes and it’s not working. It would be helpful to get an update as to when it’ll be fixed to not pay money for nothing.

This has been broken for at minimum four full months, I am just going to cancel my subscription and find alternate means. The lack of communication and quick resolution of a feature of paid software is absolutely horrendous.

I know. Its getting ridiculous that we don’t even have a general eta. I ended up getting lipsurf premium just so can at least use it for English answers, but for Japanese it won’t work At this point i could just use dragon text to speech for the same result.

I literally just purchased this software specifically so that I could do my Wanikani reviews and lessons with my voice, so I don’t have to constantly make my wrist and hands hurt… so the revelation that this doesn’t actually work is really a let down and a literal pain. I guess I’m going to have to ask for refund from this month, unless this gets fixed asap.

I am also a software engineer, and I would also honestly be more than happy to help fix this issue.

The WaniKani plugin has been rewritten to work with the new version of WaniKani. We have a fix coming for this waiting for review from the Google Chrome team, you will be upgraded automatically. Thanks for your patience!


great news! thank you miko :slight_smile:

It’s working now. Reviews are a breeze once again! Thank you Miko!

1 Like

Has this been fixed as I am having the same issues, I have to turn of Text inou in options, and it will only work on reviews, no lessons, recent mistakes or burned items